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Glossary of Terms 
 

AutoQC............... The section of PeCOD® Pro for performing automated QC-Routines. 

Calibration........ The operation the PeCOD® instrument performs using calibrant and blank to calibrate within a  

                           given range.  

L100.................... The lab version of the PeCOD® COD Analyzer. 

PeCOD® Pro....... MANTECH PeCOD® control software 

peCOD................ Photoelectrochemical chemical oxygen demand 

PeCOD® ............. Instrument for analysing the COD of a liquid via peCOD method. 

QC-Check........... A sample run on calibrant to verify the calibration of the instrument, i.e. analyzing a sample 

with a known COD.  

QC-Routine........ The series of operations which includes x number of calibration operations and y number of 

QC-Checks. 

QC-Regime........ The three re-configurable definitions of the automated behaviour which allows for 

calibration/calibrant readback behaviour, evaluation of results and re-attempts if required. 

Sample............... Verb: The operation of analysing a sample (noun). Noun: The liquid being analysed. 
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Program Description 
PeCOD® Pro is Windows software designed to operate an L100 PeCOD® COD Analyzer. PeCOD® Pro 

allows for: 

• automated calibration 

o “AutoQC” can be configured to run a series of calibrations, and QC readbacks, and to 

repeat these operations in the case of an error, or the QC check being out of range. 

• sampling and sample reporting  

o samples can be organized into groups, calibration data associated with samples, 

correlations added for reporting, etc. 

• live plotting data 

o raw Iwork vs time plotting during operations. 

• instrument configuration/diagnostics 

 

Installation 
If a PC was not provided by MANTECH, please refer to the following instructions for installation.  

 

Requirements 
• PeCOD® Pro is currently only available to be installed on computers with .NET 4.5.2 or 

greater. As such Windows 7 or later is required for compatibility.  

Installation Instructions 
• Install the CP210x USB-to-Serial driver (required to communicate with PeCOD®). 

• Ensure that the .NET framework is at version 4.5.2 or higher. This can be verified, or 4.5.2 

installed, by launching the NET4_5_2_OFFLINE_32_64.exe installer found on provided USB.  

• To ensure that automated operations are not interrupted: 

o Ensure that the Windows Automatic Update is disabled. Via: Control Panel\All Control 

Panel Items\Windows Update\Change settings and set to ‘Download updates but let 

me choose whether to install them’.  

o Ensure the power settings of the computer are set in such a way that the computer 

will not sleep or hibernate if left unattended for extended time periods.  

• Double click the PeCODProInstaller icon and follow the on-screen prompts, using the default 

selections. The PeCOD Pro software is now installed. 

 

Updating Software 
 

PeCOD® Pro contains an automatic update checking utility. If the program is connected to the 

internet, part of the start-up procedure involves PeCOD® Pro checking MANTECH servers to see if a 

software update is available. If available, the updater will list the version number and change log 

when prompting the user to update (or not). If no update is available, then the program starts 

normally. 

 

The automatic update checking can be disabled by a setting under “File>Preferences”. 
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Basic Operation 
 

Establishing Communication with an L100 
• L100 Preparation, ensure: 

o there is power to the L100.   

o the USB cable is plugged into both the PC and L100.  

o the L100 is not already connected to another program (Labterm, PC-Titrate, etc). 

o A, B, and Waste tubes are in vessels with fluids available, as appropriate.  

• Launch the PeCOD® Pro exe. 

o Click the “Port” dropdown list, and select the COM port associated with the L100 

(typically configured for COM6).  

o Click “Connect”, the software will try to connect and determine the current reagent 

pack range, PeCOD® serial #, etc. which will automatically determine certain software 

settings. 

Configuring an AutoQC Operation 
If PeCOD® Pro is being used to run a QC-Routine select the “AutoQC” tab. 

1. Specify the require pre-operation priming (dependant on tubing length, 3 per port is typical). 

2. Select the QC-Regime to use (Daily Startup, New Sensor, or QC-Check). 

3. Specify the desired delay-start date/time (or none). 

4. Click on the start button. 

5. When completed select the “AutoQC Report” tab to view the results or generate a printable 

report. 

Configuring a Sampling Operation 
If PeCOD® Pro is being used to run a sample, select the “Sample” tab. 

1. Create a new batch, or load an existing batch you wish to add to. 

2. Verify/Update the current calibration data (when the sample is run, the current calibration 

data will be associated with that sample). 

3. Enter a sample name, set the number of replicates and click “Run Sample(s)”. 

a. “0” replicates indicates that 1 sample will be run, with 0 repetitions afterwards. 

b. “1” replicates indicates that 1 sample will be run, with 1 repetition afterwards, for a 

total of 2 results. 

4. When completed select the “Sample Reports” tab to view the results, or generate a printable 

report. 

Monitoring Operations/Results 
• Live data from the operation in progress can be monitored on the “Live Plot” tab. 

• After a calibration or QC-check is completed, PeCOD® Pro collects the updated data from the 

instrument. Via the “AutoQC Report” tab, select the QC-Routine ID from the drop-down (if 

not already selected) and press the “Refresh” button to update the table. 
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• After a sample is completed, PeCOD® Pro collects the updated data from the instrument. Via 

the “Sample Report” tab, select the Batch ID from the drop-down (if not already selected) and 

press the “Refresh” button to update the table and other data labels. 

 

• Full Primary Log, Secondary Log, Calibration Log, and Event Log data can be update from the 

instrument via the “Logs” tab by selecting the appropriate log type from the drop-down and 

pressing the “Get Logs from PeCOD®” button. It is not recommended to update these logs 

while the L100 is performing another operation, as it could result in an internal instrument 

error which will cause the current operation to fail. 

http://www.mantech-inc.com/
mailto:info@mantech-inc.com


 

Page 5 of 17 

 

www.mantech-inc.com                                              info@mantech-inc.com 
 

MANTECH 

5473 Highway 6 North 

Guelph, Ontario, Canada N1H 6J2   

 P:  (519) 763-4245    

www.mantech-inc.com   

Program Detailed Description 
Overview 
Outline of the main portions of the program. 
 

 
 
 

1. Menu Items: Contains preferences and utilities. 

2. USB COMM.: Shows current USB/Serial connection to intrument, and current reagent pack. 

3. Status: Displays current instrument/program status and the current sensor usage data. 

4. Manual Control: Shows current instrument display, allows mirror control of instument front 

panel, and contains quick buttons for priming/operations. 

5. Tab Page Selection: Selection betweween different tabbed pages. 

6. Tab Page: The interior content of each tabbed page. 

7. Status Strip: Gives limited status information about the programs current state. 
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Menu Items  
The items contained in the top menu.  

1. File>Preferences:  

a. Contains various general program options. 

b. Contains the options for the acceptable passing criteria for calibrations/qc-checks. 

c. Contains the options for the behaviours of the 3 QC-Regimes. 

2. Help>About: Provides details regarding the current version of PeCOD® Pro. 

3. Help>Serial (raw): Contains log of the command communication, used for troubleshooting. 

4. Help>Check for updates...: Allows the user to manually check for updates (updater checks 

for new version when program starts, and will prompt user if a new version is available). 

Preferences 
The preference options available via File>Preferences 

 

1. Update Related Options 

a. Checkbox to enable/disable automatic 

update checker. 

b. Button to re-show most recent 

update tour. 

c. Button to open updater for beta-

modes. Should only be used under 

the direct instruction from a 

MANTECH representative. 

2. Button to clear the saved PeCOD serial 

numbers and related inter-session calibration 

data. 

3. Sensor Related Options 

a. Checkbox to disable the warning if no 

sensor is configured as the current 

sensor. 

b. Button to clear all saved senor data. 

4. Form Closing Options 

a. Button to close the preferences form 

and save the changes. 

b. Button to close the preferences form 

and ignore the changes. 

5. The QC-Passing Criteria Selection 

a. Drop-down to select the range to 

configure. If a PeCOD is connected, its 

current range is automatically 

selected when the Preferences form 

is opened. 

b. Button to restore the 5c options to 

their defaults for the range selected 

in 5a. 
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c. The acceptable passing criteria 

for calibrations and QC-checks, 

on a per range basis, as selected 

in 5a. These values are used in 

the auto-qc tab based operations. 

6. Tab selection for each of the 3 available 

QC-Regimes 

7. The initial calibration attempt. 

a. The number of initial calibrations 

to attempt. 

b. Which calibration to begin 

evaluating the result to continue 

or not. Evaluation criteria are 

selected in 8, and the values 

defined in 5. If a calibration 

passes, the QC-routine continues 

to 9. If none pass, the QC-routine 

is stopped. 

8. The selection of what criteria to use to 

evaluate 7. 

9. The initial calibrant readback attempt. 

a. The number of calibration readbacks to perform at maximum. 

b. The calibration readback to begin evaluating the result. Criteria selected in 10, 

defined in 5. If the calibrant readback passes, the QC-routine ends in success. If it 

fails, a re-calibration is attempted in 11. 

10. The selection of what criteria to use to evaluate 9. 

11. The repeated calibration which is performed if 9 fails. 

a. The maximum number of re-calibration attempts. Every calibration is evaluated by 

the criteria in 12. If the re-calibration passes, a new calibrant readback is performed 

in 13. If no calibration passes, the QC-routine ends in failure. 

12. The selection of what criteria to use to evaluate 11. 

13. The maximum number of re-calibration readbacks to perform. Each calibrant readback is 

evaluated based on the criteria in 14. If a calibrant readback passes, the QC-routine ends in 

success, if none pass the QC-routine ends in failure. 

14. The selection of what criteria to use to evaluate 13. 

15. Button to return the 7-14 selections to their default values. 

Communication Configuration  
USB connection status. 

1. COM port selection  

a. L100 is typically configured to COM6. This can be configured 

in Windows Control Panel/Device Manager. The L100 appears 

under Ports (COM & LPT) as “Silicon Labs CP210x to UART 

Bridge” 

2. Connect/disconnect button. 

3. Connection status indicator. 

4. Current reagent pack, i.e. colour range. 
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Status  
General status of PeCOD. 

 

1. Serial # of L100, used to save data between 

sessions. 

2. Currently selected sensor, and running total 

of uses. Button to open “Sensor 

Management” where new sensors can be 

added and the current sensor changed. 

3. Current Status: most recent status message.  

 

 

Manage Sensors 
Tool to manage the historical sensor data and the currently selected sensor. 

1. Currently selected sensors. 

a. Data regarding the currently 

selected sensors. 

b. List of available sensors. 

c. Button to make the 1b. sensor the 

active sensor. 

d. Button to deleted the sensor 

selected in 1b. 

e. Button to clear all sensors and 

associated data of all sensors listed 

in 1b. 

2.  

a. Input field for adding a new sensor 

serial number. 

b. Button to add that sensor to the 

stored sensor list, and make that 

sensor the currently active sensor. 

3. Historical sensor data. 

a. Table listing sensor data. 

b. Button to copy the current table to the clipboard. 

c. Button to save the current table to a CSV file. 

4. Loading sensor data. 

a. Button to load sensor data from a CSV file, and clearing the existing data. 

b. Button to load sensor data from a CSV file, appending new entries, and skipping any 

entries that already exist in the table. 

5. Closing  

a. Button to close the Manage Sensors form and save the changes. 

b. Button to close the Manage Sensors form and abandon the changes. 
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Manual Control  
Allows manual control of the instrument through virtual front panel buttons and macro functions. 

 

 

 

 

 

 

 

 

1. Mirror of interument display. 

2. Quick buttons for priming port A and/or port B, either 1 or 3 times. 

3. Mirror control buttons which behave as if manually using the L100 front panel buttons. 

4. Unatteneded calibrate and unattended analysis buttons. Results will not be recorded in 

the software if selected. 

 

AutoQC Tab  
Allows for set-up and execution of automated QC routines with or without a start-time delay. 
 

 
 

1. QC-Routine ID: Unique ID to identify the QC-Routine being performed. It is used in the 

AutoQC Report and when saving/loading calibration data (for reporting). 

2. QC-Routine Configuration: 

a. The number of times to prime the A and B port respectively. 

b. The QC-Regime selection. 3 Options are available, for convenience.  The details of 

each regime are defined in the File>Preferences menu. 

3. QC Delay 

a. No Delay can be selected to start immediately. Delay Start Until can be selected to 

delay the start of the routine until a later date/time. 

b. The delayed start date/time is configurable here. 

4. Post QC 

a. Checkbox to automatically save the AutoQC report data to file or not. Filename is 

take from the Calibration ID. The location is configurable by the user. 
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b. Checkbox to automatically save the raw operational curves to file or not. Filename is 

take from the operation type and the date/time when it is performed. The location is 

configurable by the user. 

5. Operational Buttons  

a. Button to start the routine, as configured by the previous selections. 

b. Button to cancel the routine in progress and/or reset these options after a routine is 

complete. 

 

AutoQC Report Tab  
Organises the results of AutoQC operations and allows for saving/loading of results and printable 

report generation. 

 

 
 

1. Report Configuration 

a. Dropdown to select the QC-Routine to be displayed. Calibrations run during this 

session via AutoQC tab will automatically be available in the list. Prior calibration 

data can be displayed if loaded from file. 

b. Button to refresh the contents of 2. 

c. Button to load previous calibration data from file. 

d. Button to save calibration data to file. Saved as .cal file. Contains more information 

than available in the table, e.g. calibration ID, L100 serial #, etc. 

e. Button to generate a printer friendly report. 

f. Button to save the current table to CSV. 

g. Button to copy the current table data to the clipboard. 

2. Data table. 
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Sample Tab   
Allows samples to be analysed, application of calibration data related to the analysis, and grouping 

any other relevant information to a specific sample analysis.  

 

 
 

1. Batch Selection 

a. Dropdown to select the current batch (batches initiate the session, or previous 

batches loaded from file). The Batch selected from the dropdown is where the 

sample result will be added to. 

b. Button to create a new batch. 

c. Button to load previously created batches from file. 

d. Button to save the current Batch to file. 

2. Batch Info - populated/associated with selection in 1a 

a. Unique Batch ID, (default name is date/time formatted as: 

Batch_YYYYMMDD_hh_mm_ss 

b. Name of the operator (optional). 

c. Notes (optional) 

d. Button to update the batch if changes are made in 2a-2c. Changes are also saved 

when a sample is run. 

3. Calibration Data Associated with Next Sample - when a sample is run, the data in this group 

will be associated with selected calibration. 

a. Dropdown selection of different methods of updating calibration data. Calibration 

data will automatically update if any calibrations/QC checks are run via the AutoQC 

tab within this session. Most recent data is saved between sessions that is associated 

with L100 serial #. 

b. Button to implement the update, as specified in 3a. 

c. Currently loaded calibration data. 

4. Sample Configuration 

a. Number of times to prime Port A before analyzing. 

b. Number of times to prime Port B before analyzing. 

c. Sample ID. 
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d. Number of replicates to perform automatically after the initial sample analysis. “0” 

indicates that the sample will be analyzed 1 time, with 0 replicates. “1” indicates that 

the sample will be analyzed 2 times (1 original, 1 replicate), etc. 

5. Post-Sample Configuration 

a. Checkbox to determine if the batch data should be automatically saved to file when 

completed or not. 

b. Button to change the location for automatic batch data saving. 

c. Checkbox to determine if the raw curve data should be automatically saved to file 

when completed or not. 

d. Button to change the location for automatic curve data saving. 

6. Operational Buttons  

a. Button to run the sample/any replicates. 

b. Button to cancel the operation in progress. 

7. Indicator of the operational status in the sample/replicate schedule. 

 

Sample Report Tab  
Organises the results of Sample operations and allows for saving/loading of results and printable 

report generation. 

 

 
 

1. Report Selection 

a. Dropdown to select the batch of interest. Batches that have been run in the current 

session or previously saved to file will be in dropdown menu.  

b. Button to refresh the data/table. 

c. Button to load a previously performed batch from file. 

d. Button to save the batch data to file. 

e. Button to add/remove/modify custom COD correlation data columns (see next page). 

f. Button to generate a printable report of the batch. 

g. Batch Operator. 

h. Operator’s notes. 

2. Associated Calibrations 
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a. Dropdown to select the associated calibration. Associated calibrations are 

automatically numberd as they are generated (1, 2, 3, etc). 

b. Associated calibration data. 

3. Table Tools 

a. Button to save the table data to a CSV file. 

b. Button to copy the table data to the clipboard. 

4. Table showing sample data and any COD correlations added in 1e. 

 

 

Add/Edit COD Correlation 
If button 1e in Sample Report is clicked, the dialogue below is shown. 

 

1. Correlation Selection 

a. The currently selected 

correlation. 

b. Button to create a new 

correlation. 

c. Button to delete the 

currently selected 

correlation 

2. Editing the selected correlation. 

a. Box to modify the 

correlation name. 

b. Radio button to select a 

maually entered y=mx+b 

equation of a correlation 

line. 

c. m (slope) value of 

correlation line. 

d. b (offset) value of 

correlation line. 

e. Radio button to select automatic correlation line creation from a series of points 

i. Allows for best fit, or linear interpolation between points (see next page). 

f. Button to open the multipoint tool. 

3. List to select which sample to apply the correlation to. 

4. Button to save changes and close. 
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Multi-Point Tool 
If Equations from Points is specified the Multipoint tool must be populated. 
Create single equation least squares fits, or multi-equation linear interpolation between user 

entered data, to be used to create correlations to COD data in reports. 

 

1. Plot showing the current points/ lines. 

2. Enter COD values, and the desired 

correlated values. 

3. Button to update the plot/equations 

based on changes in 2. 

4. Button to clear the data in both 2 & 5 

5. Equation(s) generated from the data in 

2.  

6. Conversion tool for testing values 

based on the equations in 5. 

7. Selection of fit type. 

a. Least squares creates a single 

linear equation of best fit. 

b. Linear interpolation creates 

several equations to linearly 

interpolate between points. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

1 

2 3 4 
6 

7 
5 
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Live Plot Tab  
Shows the Time(s) vs I Term (µA) data generated during an operation. 

 

 
 

1. Data: Summary of instrument data relevant to the plot. 

a. The total time, sum of the individual stage times. 

b. The current time of the current sub-operation stage. 

c. The current LED current value. 

d. The current IWork value. 

e. The port applicable to the current stage. 

f. The current sub-operation stage. 

2. Chart Tools: Tools for manipulating the chart. 

a. The maximum Y axis value to scale the Y chart to. 

b. The window width (in seconds) of the X axis window to display 

c. Enable/disable the horizontal line which indicates the previous stages ITerm. 

d. Enable/disable displaying the last X points of the curve (allows for an easier visual 

estimate of signal noise). 

e. Check box to allow for Auto Scroll of X Axis as the L100 calibrates or completes an 

analysis.  

f. Button to save the current X/Y data displayed to a CSV file. 

3. Shows the plot of IWork (uA) vs Time (s) 
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Settings Tab  
Displays and allows changes of L100 parameters. 

 

 
 

1. Common Parameters and quick change options. 

2. Button to update the L100 date and time to match the current PC date and time. 

3. Precision, and button to write them to the L100. 

4. Target I term, and button to write them to the L100. 

5. Reagent pack selections, and button to write them to the L100. 

a. The other parameters that are automatically changed when reagent pack is changed. 

6. Advanced Parameter Options 

a. Selection of the type of parameters to change: controller or analyser. 

b. Button to read the parameters from the PeCOD®. 

c. Dropdown selection of the current parameter. 

d. Value of the parameter selected in 6c 

e. Button to update the currently selected parameter. 

7. Additional Parameter Options 

a. Button to load a parameter file and apply it to the PeCOD®. Note that this only 

applies to the controller or the parameter, depending on what is currently selected 

in 6a. 

b. Button to save the current parameters (in PeCOD®Pro) to a file. Note that this only 

applies to the controller or the parameter, depending on what is currently selected 

in 6a. 

c. Button to save the current parameters on the PeCOD®as the factory settings. Note 

that this only applies to the controller or the parameter, depending on what is 

currently selected in 6a. 

d. Button to restore the PeCOD®to the saved factory settings. Note that this only applies 

to the controller or the parameter, depending on what is currently selected in 6a. 
 

 

 

 

 

 

http://www.mantech-inc.com/
mailto:info@mantech-inc.com


 

Page 17 of 17 

 

www.mantech-inc.com                                              info@mantech-inc.com 
 

MANTECH 

5473 Highway 6 North 

Guelph, Ontario, Canada N1H 6J2   

 P:  (519) 763-4245    

www.mantech-inc.com   

Logs Tab  
Contains the operation log of the software (per session) as well as displaying Primary, Secondary, 

Calibration, and Event logs from the L100. 

 

 
 

1. Status Log 

a. Text log of the operations performed in this session of PeCOD® Pro. 

b. Button to copy 1a to the clipboard. 

c. Button to save 1a to file. 

d. Button to clear 1a. 

2. PeCOD® Logs 

a. Drop down to select the log type. 

b. Button to update the table data from the L100. 

c. Button to clear the log from the L100. 

d. Button to save the current table to file. 

e. Button to copy the current table to the clipboard. 

3. Table of log data. 
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Data-Structures  
A variety of data-structures are used to organize information in PeCOD®Pro: 

 

• QC-Routine: Contains the information from all the operations performed during a single QC 

routine, which can include multiple calibrations and multiple QC-Checks in addition to other 

information about the QC-Routine. Can be saved/loaded as a “.cal” file, or used to generate a 

printable report. 

• Calibration: Contains the results of the Calibration operation. 

• QC-Check: Contains the results of the QC-Check operation. 

• Batch: The results from one or more samples, the current (and possibly different) 

calibration data at the time each sample is run, and other information about the group. Can 

be saved/loaded as a “.batch” file, or used to generate a printable report. 

• Sample: Contains the results of the Sample operation (single or replicate). 

• Associated Calibration: The summary of the current calibration information when a sample 

is run in a batch. Contains a single calibration, a single QC check, an ID (numbered 1,2,3... as 

needed in each unique batch) and other information about the calibration state. Multiple 

samples can have the same associated calibration – only if the calibration did not change 

between samples. 

 

Each of these data-structures contain the following child elements: 

 

QC-Routine Batch    

• L100 Serial # • Batch ID 

• L100 Range • Notes 

• Pass Conditions • Operator 

• Calibration 1 • L100 Range 

• Calibration 2 • Pass Conditions 

• Calibration…. • Sample 1 

• Calibration n • Sample 2 

• QC-Check 1 • Sample…. 

• QC-Check 2 • Sample n 

• QC-Check…. • Associated Calibration 1 

• QC-Check m • Associated Calibration 2 

 • Associated Calibration…. 

 • Associated Calibration m 

 

Calibration or QC-Check Associated Calibration Sample 

• Date/Time • L100 Serial # • Date/Time 

• Type • L100 Range • Sample ID 

• M (COD/uC) • Pass Conditions • Qnet (uC) 

• C (uC) • Associated Calibration # • COD (mg/L) 

• LED (mA) • Calibration • Iterm (uA) 

• COD (mg/L) • QC Check • Associated Calibration # 

• Qnet (uC)   

• Iterm (uA)   

 

 

http://www.mantech-inc.com/
mailto:info@mantech-inc.com

